侧边栏壁纸
博主头像
波哥

大龄程序猿&自由职业者&副业达人
爱好:敲代码、搞副业
12+年开发经验,热衷自动化网络推广!

  • 累计撰写 1,810 篇文章
  • 累计创建 77 个标签
  • 累计收到 13 条评论

目 录CONTENT

文章目录

【java报错】java: 错误: 不支持发行版本 5

波哥
2021-10-18 / 0 评论 / 0 点赞 / 199 阅读 / 0 字
java: 错误: 不支持发行版本 5
排查完所有的IDEA设置后,代码仍然报错不支持的发行版5,是因为pom文件默认是jdk1.5,所以需要标明是哪个jdk版本。
pom.xml文件加入properties,注明jdk版本号
<properties>
        <maven.compiler.source>11</maven.compiler.source>
        <maven.compiler.target>11</maven.compiler.target>
</properties>
0

评论区