侧边栏壁纸
  • 累计撰写 2,058 篇文章
  • 累计创建 73 个标签
  • 累计收到 20 条评论

目 录CONTENT

文章目录

类文件具有错误的版本 61.0, 应为 52.0

大猿本猿
2023-04-20 / 508 阅读 / 198 字

错误描述

java: 无法访问org.springframework.web.socket.server.standard.ServerEndpointExporter
错误的类文件: /D:/Devtools/Maven-3.8.3/repository/org/springframework/spring-websocket/6.0.6/spring-websocket-6.0.6.jar!/org/springframework/web/socket/server/standard/ServerEndpointExporter.class
类文件具有错误的版本 61.0, 应为 52.0
请删除该文件或确保该文件位于正确的类路径子目录中。

解决方法

SpringBoot使用了3.0或者3.0以上,因为Spring官方发布从Spring6以及SprinBoot3.0开始最低支持JDK17,所以仅需将SpringBoot版本降低为3.0以下即可。

pom加入parent:


    <parent>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-parent</artifactId>
        <version>2.3.12.RELEASE</version>
        <relativePath /> <!-- lookup parent from repository -->
    </parent>

类文件具有错误的版本 61.0, 应为 52.0